Possible Causes of AddOns Not Working

If one or more AddOn(s) is/are not working in-game, here are some possible causes:

Problem #1: The AddOn does not show up at the 'My Installed AddOns' section of WowMatrix.

Solution: Install the AddOn via the 'Get More AddOns' section of WowMatrix.

Problem #2: The AddOn DOES show up at the 'My Installed AddOns' section of WowMatrix, but when I log into the game, I do NOT see a red 'AddOns' button at the lower-left corner of my character selection screen.

Solution: Right-click the WoW game icon that you normally run the game with. Select 'Properties' from the menu, then click the 'Open File Location' (or 'Find Target') button. The 'World of Warcraft' folder should open. Make a note of the exact location shown at the top of that window. Now open WowMatrix, wait for it to finish scanning, then click the 'Settings' button. Make sure it is pointing to the same location (change it if it isn't). Install the AddOn again if it is no longer listed at the 'My Installed AddOns' section.

Problem #3: The AddOn DOES show up at the 'My Installed AddOns' section of WowMatrix, but does NOT show up when I click the red 'AddOns' button at the game's character selection screen.

Solution: First of all, make sure you are opening WoW (the game) after installing the AddOn, otherwise WoW will not know that a new AddOn has been added.

If you are already doing this, and are still experiencing the problem, then there are 2 possible causes:

a) Right-click the WoW game icon that you normally run the game with. Select 'Properties' from the menu, then click the 'Open File Location' (or 'Find Target') button. The 'World of Warcraft' folder should open. Make a note of the exact location shown at the top of that window. Now open WowMatrix, wait for it to finish scanning, then click the 'Settings' button. Make sure it is pointing to the same location (change it if it isn't). Install the AddOn again if it is no longer listed at the 'My Installed AddOns' section.

b) If you are running Windows Vista or higher, and your 'World of Warcraft' folder is located inside the 'Program Files' folder, then you can either move the 'World of Warcraft' folder out of the 'Program Files' folder (this is also recommended by Blizzard), or if you do not wish to move the folder then you may use the 'Launch WoW' button in WowMatrix to open the game.

Problem #4: The AddOn DOES show up at the 'My Installed AddOns' section of WowMatrix, AND also when I click the red 'AddOns' button at the game's character selection screen. However, it does NOT work when I log into my character to play.

Solution: Click the red 'AddOns' button at the game's character selection screen. Now make sure the correct character is selected from the drop-down menu at the top. Then make sure the checkbox to the left of the AddOn is both GOLDEN and CHECKED. If it isn't, keep clicking on the checkbox until it is. Then click the 'Okay' button.

Problem #5: The AddOn DOES show up when I click the red 'AddOns' button at the game's character selection screen, AND the checkbox to the left of the AddOn is both GOLDEN and CHECKED. However, it STILL does not work when I log into my character.

Solution: Try logging into your character and typing a slash followed by the name of the AddOn, and then press the key on your keyboard. For example, to see the menu for AlphaMap, type the following command in-game:

/alphamap

This should bring up the AlphaMap options screen. You can then adjust the necessary settings there.

Hope this helps. Happy gaming!